Python 3.6 Requests version mismatch with docker-compose requirements
Closed, ResolvedPublic


After recent update, running any docker commands will result in an Exception thrown

raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (requests 2.18.4 (/usr/lib64/python3.6/site-packages), Requirement.parse('requests!=2.11.0,<2.12,>=2.6.1'), {'docker-compose'})

docker-compose v1.17.1 requires an older version of requests.
If requests is rolledback to 2.11 it fixes the issues

yursan9 added a subscriber: yursan9.Feb 6 2018, 7:31 PM

We need to update docker-compose actually. Current version in the repo is behind the released one.

@yursan9 yes, I believe so. Just provided a workaround, asked about on IRC, but got no reply, I too believe docker-compose needs a version bump

I'll try to update it. But it's still need the core team approval, and waiting for next-sync.

Alternative now is to pull the updated version from unstable:

sudo eopkg install

Thanks so much @yursan9 just applied the latest update, worked like a charm!