Page MenuHomeSolus

Entangle Not Starting Due to Outdated Library
Closed, InvalidPublic

Description

When attempting to start Entangle, nothing happens.
So I tried opening it via the terminal to see any errors, and this is what I got:

entangle: error while loading shared libraries: libexiv2.so.14: cannot open shared object file: No such file or directory.

I am guessing that the libexiv library is outdated, however I do not see any available updates for either exiv2, or libexiv2.

moriel5 created this task.Nov 6 2017, 8:25 AM
moriel5 updated the task description. (Show Details)Nov 6 2017, 8:25 AM
sunnyflunk added a subscriber: sunnyflunk.EditedNov 6 2017, 8:45 AM

What's the output of

eopkg lr

You seem to have a hybrid unstable/shannon system...

Justin triaged this task as Normal priority.Nov 6 2017, 11:17 PM
Justin edited projects, added Software; removed Lacks Project.
moriel5 added a comment.EditedNov 8 2017, 7:18 AM

Nay, I do not mix packages between the stable and unstable Solus repos.
I do add software manually when it is unavailable on Solus, however I almost never touch Entangle, due it only being there to help me check whether I can connect old video cameras.

As to the output of eopkg lr, it is unsurprisingly:

Solus-Unstable [active]

https://packages.solus-project.com/unstable/eopkg-index.xml.xz

The first thing I generally do on my personal computers (as in mine, not anyone else's) is remove the stable repo, and add the unstable repo (and activate it).

Entangle loads fine on fully updated unstable. Suggest you update your system and if that doesn't fix it, validate your packages as per

https://solus-project.com/articles/troubleshooting/general-troubleshooting/en/

Thanks, I'll do that in a few moments and post the results.

Sorry for the delay, I had to rush to work.
Apparently today's updates (I did not have time to check what was updated, so I do not know whether this is true) may have fixed this issue.

Entangle works fine now (although I do wish it had a light theme, however that is beside the point).

sunnyflunk closed this task as Invalid.Nov 8 2017, 11:46 PM

Note: there was never really an issue...unstable will always have ABI breaks, which then get fixed (likely before you even made this task). You merely updated before all rebuilds were in and haven't update since then

moriel5 added a comment.EditedNov 9 2017, 9:19 AM

I guess that was the cause (although I had made this task right after updating my system, that was why I did not find any updates back then (I had guessed that Entangle was updated before it's required libraries)).

Anyways, thanks a lot (it is just too bad that my Samsung camcorder (I finally remembered the correct term) is still not recognized by Entangle, I think that I am going to post about it somewhere where the Entangle developers will see it (I wonder if they use GitHub?) when I'll have the time).

I think you have it backwards, exiv2 gets updated which breaks all programs that use it until they're rebuilt (for Entangle that was gexiv2 which gets pushed in the hours afterwards).

If the camcorder needs a kernel module to function, it likely needs to be enabled in the kernel.

Sorry about that, I wasn't thinking straight, you're right about that.

About the kernel mode requirement, it would be interesting what my old SCD103 may require to function, seeing as it had never gained any Linux support, and even the old Windows support page (there never was a Linux support page) had been completely pulled.