Opening two files in gedit causes system to slow down
Closed, InvalidPublic

Description

When opening a second file in gedit (so that two tabs are open) it significantly slows down the system and the cursor rotates for around 5 to 10 seconds. This looks very odd as these files are practically not consuming any resources.

baimafeima updated the task description. (Show Details)

I have multiple tabs (6+) open in gedit the whole day and I don't experience any performance issue. Could you check the processes to see if you can identify what eats your cpu power during that laps of time ?

Xorg is briefly up to 20% but I didn't notice anything unusual.

Justin added a subscriber: Justin.Nov 7 2017, 6:02 AM

Opened ~80 tabs and no slowdown.

Sounds more like a IO-related issue with your hardware than an issue with gedit itself.

crom5 added a subscriber: crom5.Nov 7 2017, 4:14 PM

I'm experiencing the same problem when opening two or more gedit windows/files (Asus and Lenovo powerful laptops).

@JoshStrobl Any specific commands I can run to track down the problem?

It looks like this only happens when I either open a second Gedit instance or click on a file in the file manager but not when using the plus tab symbol inside of Gedit.

Have opened two gedit windows with 2 files in each and not seeing any slowdown, how big are the files you have open? Are they a specific encoding? Are they saved on an external drive?

On my original internal "NVMe SSD" drive I created now two new files in my "Dowloads" folder: "blabah_1" (11 bytes) and "blabah_2" (11 bytes). They both content just one single word: "blabah". If I open only one of them, everything is ok - but if I open both two files, cursor rotates for around 10-15 seconds: rotating cursor is visible only if I move the cursor over the left dock panel or at the top of the screen over the file name. Cursor continue to rotate even after closing both two files and Nautilus too.

Video: http://cromalternativemoney.org/slike/video_gedit_problem.mp4

By the way, what do you think about LibreOffice cold start time (at the end of video)?

Have opened two gedit windows with 2 files in each and not seeing any slowdown, how big are the files you have open? Are they a specific encoding? Are they saved on an external drive?

Just plain text files, nothing out of the ordinary. Saved on an internal SSD.

I had the exactly the same issue that @crom5 illustrated in the video. Since some time, however, when I click on files in the file manager they open in separate Gedit instances instead of using the same Gedit instance but with multiple tabs. Were there any changes made during the past days? It looks like it could be circumvented like this but now I feel that separate Gedit instances are less preferable than actually having multiple tabs.

DataDrake closed this task as Invalid.Thu, Jul 12, 6:33 PM
DataDrake added a subscriber: DataDrake.

Can't reproduce, though I expect it is likely a cursor bug like we saw with Budgie ages ago.