Image thumbnails lost after software update
Closed, ResolvedPublic

Description

Installed SOLUS 3, image thumbnails worked fine. After applying software updates, no image thumbnails.

swelch created this task.Oct 15 2017, 2:42 PM

One of my computers is having this issue (laptop), the other isn't (desktop).

Additional info:

  • Thumbnail generation of both images and video is affected.
  • Previously generated thumbnails still work, it's the generation of new thumbnails that is failing.
  • Clearing out ~/.cache/thumbnails/fail shows that it is -trying- to generate thumbnails, but failing.
  • The issue is the same on both local and remote files.
willgfx added a comment.EditedOct 15 2017, 4:40 PM

Found this: https://bugzilla.gnome.org/show_bug.cgi?id=785963

Installing bubblewrap fixed the issue on my laptop (it was already installed on my desktop).

Should bubblewrap be added as a rundep for nautilus (or some other part of the gnome stack)?

No it wasn't. @willgfx discovered after that commit that even a rebuilt ffmpegthumbnailer does not resolve the issue.

DmitryS added a subscriber: DmitryS.EditedOct 16 2017, 10:04 PM

Found this: https://bugzilla.gnome.org/show_bug.cgi?id=785963

Installing bubblewrap fixed the issue on my laptop (it was already installed on my desktop).

Should bubblewrap be added as a rundep for nautilus (or some other part of the gnome stack)?

After installation of the 'bubblewrap' and removing '~/.cache/thumbnails' icons displayed again as before update to gnome 3.26.1.
Thanks for hotfix solution!

In T4773#84992, @Justin wrote:

I believe this fixed the issue: https://dev.solus-project.com/R743:1a9c4cc45a1c819cb7cbd2d3fb9c7bceae61a0db I may be wrong though.

I installed bubblewrap from the software center. The problem is mostly fixed. There are still some random JPGs that display thumbs and then later they don't. Cutting and pasting them back restores the thumbs but then sometimes they go away - but mostly it's working now. Appreciate the troubleshooting!

JoshStrobl edited projects, added Software; removed Lacks Project.Oct 17 2017, 12:41 AM
JoshStrobl moved this task from Backlog to Package Fixes on the Software board.
JoshStrobl triaged this task as High priority.
ikey closed this task as Resolved.Oct 18 2017, 10:06 PM
ikey claimed this task.
ikey added a subscriber: ikey.

Fixed